Eonon GA9351 Help - Mazda3 Forums : The #1 Mazda 3 Forum
 1Likes
  • 1 Post By theblooms
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 12-18-2019, 07:17 AM Thread Starter
Moped Rider
 
Dedylan's Avatar
 
Join Date: Apr 2014
Location: Upstate NY
Posts: 15
Eonon GA9351 Help

Hey everyone!

I have two questions regarding the Eonon GA9351 head unit and A0585 dongle in my 2009 Mazda 3:

1. Has anyone had any issues with the USB periodically not working? Some days, I'll plug my USB and phone into the system and it doesn't recognize either.

2. When the USB does work, I am having issues with the CarPlay integration . I orginally had the Autokit APK, which worked fine minus the issue described in question 1, but then Eonon customer support directed me to download the EPlay application. When I plug in my dongle, it gives me the error, "The product is not authorized. Please contact the dealer." Is there another application that works better or some sort of firmware update I need to make it work?

Has anyone had either of these issues with this head unit or previous ones? Thanks in advance!

Dylan Kovach
2009 Mazda 3s 2.3L
Silver / 53K Miles

---Modification---
-Injen Cold Air Intake
Dedylan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-20-2019, 07:31 AM
Le Mans: Prototype Class
 
Join Date: Jun 2012
Location: South Carolina
Posts: 1,029
Welcome to the wonderful world of Eonon. Hope you enjoy your stay until you get completely fed up with it and stick it on eBay just to dump the piece of 💩.

I've tried three different ones. Do yourself a favor and get a CarPlay deck from a name brand. Pioneer, Kenwood, JVC, Alpine, or Sony.
Dedylan likes this.
theblooms is offline  
post #3 of 6 (permalink) Old 12-20-2019, 03:13 PM
Moped Rider
 
diegos's Avatar
 
Join Date: Aug 2015
Location: Croatia, Europe
Posts: 35
+1
I have a different model but I agree with @theblooms . Mine also gets stuck and crashes after 1h running Navi, leaving me without Navi in unknown cities, somethimes does not recognize USB drives etc etc... Now it is completely dead.
diegos is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 12-24-2019, 09:13 AM Thread Starter
Moped Rider
 
Dedylan's Avatar
 
Join Date: Apr 2014
Location: Upstate NY
Posts: 15
Quote:
Originally Posted by theblooms View Post
Welcome to the wonderful world of Eonon. Hope you enjoy your stay until you get completely fed up with it and stick it on eBay just to dump the piece of 💩.

I've tried three different ones. Do yourself a favor and get a CarPlay deck from a name brand. Pioneer, Kenwood, JVC, Alpine, or Sony.
Thanks for the response. I should have known better to just bite the bullet and buy a more expensive head unit in the first place... Kicking myself because there were deals on Black Friday. This head unit I received was the latest "version" of their unit, but there is zero software support for the CarPlay/Android Auto function. The AutoKit program only works in the compatibility function, which is low quality and glitchy.

I guess im going to have to look into saving my pennies for a better unit...

Dylan Kovach
2009 Mazda 3s 2.3L
Silver / 53K Miles

---Modification---
-Injen Cold Air Intake
Dedylan is offline  
post #5 of 6 (permalink) Old 12-24-2019, 09:19 AM Thread Starter
Moped Rider
 
Dedylan's Avatar
 
Join Date: Apr 2014
Location: Upstate NY
Posts: 15
Quote:
Originally Posted by diegos View Post
+1
I have a different model but I agree with @theblooms . Mine also gets stuck and crashes after 1h running Navi, leaving me without Navi in unknown cities, somethimes does not recognize USB drives etc etc... Now it is completely dead.
Greatttt... Well, thanks for the honest response and I know what to expect now... This unit is all form without functionality and I regret dropping the money. I just REALLY wanted it to work out given, aesthetically, it looks great as a stock alternative. Given how many headaches I've had so far, I'm almost inclined to return to the OEM for now

Dylan Kovach
2009 Mazda 3s 2.3L
Silver / 53K Miles

---Modification---
-Injen Cold Air Intake
Dedylan is offline  
post #6 of 6 (permalink) Old 12-24-2019, 09:27 AM
Le Mans: Prototype Class
 
Join Date: Jun 2012
Location: South Carolina
Posts: 1,029
Quote:
Originally Posted by Dedylan View Post
I just REALLY wanted it to work out given, aesthetically, it looks great as a stock alternative. Given how many headaches I've had so far, I'm almost inclined to return to the OEM for now
Exactly why I tried three different ones. I so wanted it to be right. The idea behind them is just utterly amazing. However, the actual implementation is garbage.

Don't even think of trying a different brand like Erisin, Seicane, Pumpkin, Joying, Atoto, etc., either. They are all exactly the same unit, coming off of the exact same assembly line, made by the exact same OEM, a company called Shenzhen Klyde. They are all junk.
theblooms is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Visual / Audio > 2004-2009 Electronics Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8