ABS LIGHT TRAC LIGHT ON - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 02-03-2020, 01:35 PM Thread Starter
Bicycle Rider
 
Join Date: Dec 2019
Posts: 6
ABS LIGHT TRAC LIGHT ON

Every warning light on the dash is on. To give a little history it’s a 2010 Mazda 3S with 140,000 miles I replaced all four wheel bearings and ABS sensors there were no previews dash lights on before I did this. Now when driving the speedometer will quit working and the power steering will quit working and all the lights appear after being reset. Any ideas?
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-03-2020, 01:40 PM Thread Starter
Bicycle Rider
 
Join Date: Dec 2019
Posts: 6
the car is 6 speed Manuel with the 2.5 liter engine
post #3 of 6 (permalink) Old 02-03-2020, 03:51 PM
Short Track Racer
 
Join Date: Jan 2016
Location: victoria, australia
Posts: 182
were the parts fitted genuine, or ebay specials
are you confident you installed them correctly
lout is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-04-2020, 11:05 PM Thread Starter
Bicycle Rider
 
Join Date: Dec 2019
Posts: 6
The parts I ordered from Detroit Axle, I’m very confident that I’ve installed the hub assembly and wheel bearings correct. This is not my 1st go around with wheel bearings but this is my 1st Mazda. I’m just really confused about it throwing so many codes.
post #5 of 6 (permalink) Old 02-04-2020, 11:13 PM Thread Starter
Bicycle Rider
 
Join Date: Dec 2019
Posts: 6
Obd2 Report
Attached Images
File Type: png D9D8F8C4-A3F9-4E9B-9B91-C6B8B8B6DF43_1580875928766.png (477.7 KB, 1 views)
File Type: png CE4213B5-5031-4FD5-BEA1-738895A8935F_1580875940201.png (546.9 KB, 1 views)
post #6 of 6 (permalink) Old 02-04-2020, 11:17 PM Thread Starter
Bicycle Rider
 
Join Date: Dec 2019
Posts: 6
Just to update today I’ve changed engine oil and transmission fluid also. I use mobile 1 synthetic 5w-30 and mobile 1 Synthetic gear oil 75-90. I’ve taken the battery out and made
Sure it was fully charged cleared all codes. While driving I got to about 35-40 mph then all warning lights popped back on also lost the speedometer
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Suspension / Brakes

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8