I dun goofed - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 03-22-2020, 05:27 PM Thread Starter
Bicycle Rider
 
AndreAndre4's Avatar
 
Join Date: Mar 2020
Posts: 4
Garage
I dun goofed

Replaced the PCV valve on my 2006 2.3L 3S. The one way down deep in there, where you have to take off the manifold, throttle body, etc.

The operation itself goes fairly smooth, and the valve was pretty gummed-up.

I'm real careful with re-assembly, new gaskets, new o-rings, I'm sure to connect all wires and use proper torques.

I go to start...turn ignition to ON position...and no crank. Starter doesn't turn over.

My dashboard lights up, my battery has 12V, my relays work. Everything worked fine prior to this procedure.

Any ideas as to why I now have no crank.

I'm turning my attention to the starter, maybe working in the engine bay inadvertently weakened a ground wire connection?

Thanks,
AG

I'm GOOD at doing it the WRONG WAY.
AndreAndre4 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-22-2020, 05:49 PM
Moped Rider
 
Join Date: Apr 2019
Location: San Diego, CA
Posts: 44
Is it possible you bumped a wire? Either to the starter or maybe a ground too. I would recheck all connections.
You could also try measuring voltage at the starter connections to see if you are getting voltage there
Birchtree is offline  
post #3 of 6 (permalink) Old 03-23-2020, 01:53 AM
Short Track Racer
 
Join Date: Jan 2016
Location: victoria, australia
Posts: 182
i assume you checked the obvious
clutch switch or park/neutral switch if auto
lout is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-23-2020, 11:15 AM Thread Starter
Bicycle Rider
 
AndreAndre4's Avatar
 
Join Date: Mar 2020
Posts: 4
Garage
I did not check the park/neutral switch.



What should I be looking to do with it?



Why would it have reset/gone wonky all of a sudden?


Thanks

I'm GOOD at doing it the WRONG WAY.
AndreAndre4 is offline  
post #5 of 6 (permalink) Old 03-23-2020, 06:36 PM Thread Starter
Bicycle Rider
 
AndreAndre4's Avatar
 
Join Date: Mar 2020
Posts: 4
Garage
Got it.



Rolled the car off the ramps and started in Neutral.


Never doing that again.

I'm GOOD at doing it the WRONG WAY.
AndreAndre4 is offline  
post #6 of 6 (permalink) Old 03-27-2020, 11:04 AM
Bicycle Rider
 
MorrisGray's Avatar
 
Join Date: Feb 2014
Location: Rock Spring, GA
Posts: 7
So what was the problem?
MorrisGray is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8