Strange P0126 Issues - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 02-07-2020, 11:39 PM Thread Starter
Moped Rider
 
Join Date: Sep 2016
Location: California Bay Area
Posts: 42
Strange P0126 Issues

So my CEL came on while driving kind of late at night ad the next day I take it to Autozone and they pull a the P0126 code so I grab the a new thermostat and swap out my old one. Strangely enough, I had consistent temps while driving both at night and the next day when I went to Autozone. After the install and coolant flush, I get the car up to operating temp and everything seemed fine, aside from the CEL staying on. I plan on doing an oil change and spark plug replacement in the morning, for usual maintenance, and then driving over to O'Reilly's to have them clear the code and drive around for half an hour or so to see if it comes back on and to make sure I don't need anymore coolant.

The strange part is that I tested my old thermostat after finishing everything up and it opened up right away after being dunked in boiling water. Should I have replaced the temperature sensor instead? Do you think I'll still need to replace it still? I did some searching here and others who have had similar issues didn't really update their posts. I would post specific temps but my OBD2 scanner decided to take a crap on me when I tried to use it when the CEL first popped up.
dudeskee1325 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-09-2020, 06:47 PM Thread Starter
Moped Rider
 
Join Date: Sep 2016
Location: California Bay Area
Posts: 42
Update (if anyone reads this), I double checked levels and followed coolant fill procedures as per the chilton manual and cleared the code. Interestingly enough, after using my neighbor's scanner, the code was present twice. I cleared the code(s) and drove around for about 45 minutes and the code remains gone.

A one hour drive awaits me later tonight so hopefully the code doesn't return. Then, tomorrow I have an hour and a half commute in traffic and normal freeway speed driving await me so that should be a good test.
dudeskee1325 is offline  
post #3 of 5 (permalink) Old 02-11-2020, 03:48 PM
Moped Rider
 
Join Date: Apr 2019
Location: San Diego, CA
Posts: 38
Only thing I can think of is that maybe the thermostat sticking is an intermittent issue? Or at least intermittent until it gets stuck open or closed..
Birchtree is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-11-2020, 05:03 PM Thread Starter
Moped Rider
 
Join Date: Sep 2016
Location: California Bay Area
Posts: 42
Very possible, yes. As another update, a day of commuting down and nothing. Tonight I'll have to drive about the same distance but at night so we'll see if the cold was the issue.

Related to the coolant system, does anyone know if there is some kind of splash shield for the alternator? I don't know how old my current radiator is, nor do I know the age of the hoses, even though they were probably replaced since they have worm clamps on them, so a radiator and hose replacement is in order soon. Would love to not have to worry about getting my alternator wet every time.
dudeskee1325 is offline  
post #5 of 5 (permalink) Old 02-13-2020, 03:51 PM Thread Starter
Moped Rider
 
Join Date: Sep 2016
Location: California Bay Area
Posts: 42
And here we are, almost a week since the code popped up, it has remained gone. Either the cold triggered it, which I'm doubtful of since California doesn't get THAT cold, or it was an intermittent thermostat related issue.
dudeskee1325 is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8