2009 Mazda 3 Trans Limp Mode - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 09-14-2019, 03:36 AM Thread Starter
Bicycle Rider
 
Join Date: Jan 2016
Posts: 2
Angry 2009 Mazda 3 Trans Limp Mode

Hi, I have a 2009 Mazda 3 i Touring with 4 speed automatic transmission. It is a high mileage car as it just rolled over 200k. My problem started in January and would happen infrequently and progressively got worse. When the engine is cold meaning not ran for about 3 or 4 hours (I am in FL where ambient temps are not that cold) and I start it. When I put the gear selector to drive the gear number indicator on dashboard will go from 1 to 2 and then back to 1. If the gear indicator stays in 2 for too long the car makes a thump sound and goes into limp mode with AT light coming on. I then can turn off the engine, start it right back up again and everything is fine, this time when you put it in Drive it goes right to 1 and stays there and drives fine. No CEL lights at all. Mind you when it goes into limp mode the car is stationary with my foot on the brake. If it goes from 1 to 2 and back to 1 quickly everything is fine car operates normally. If you drive the car, turn it off for short period of time around an hour then start it up it will go right into gear 1 and stay there. After it goes into limp mode I scan the engine for codes and I get P0661 - Intake manifold tuning valve control circut low (Bank 1), P0894 - Powertrain, U2064 - Network. I know the P0894 indicates transmission slippage, however the car is not moving and after a re-start everything is fine. The U2064 one I am thinking maybe a loss of communication to PCM by some module? I took the car to mechanic who said my battery was dead, he put new battery in and was unable to get it to duplicate the issue. After driving home from mechanic on first cold start it flashed rather quickly gear 1,2,1 and drove fine. I am not sure why the mechanic who had car for three weeks could not duplicate issue. I have read a lot about the PCM going bad and is able to make car go in Limp mode. I am wondering if swapping out the PCM would be wasting my money? I am probably not going to rebuild the transmission due to age of car and cost. I am trying to decide if I should cut my losses now or continue. Has anyone had a similar experience? I do have a short video I posted on YouTube showing the gear indicator going from 1 to 2 and back to 1, however I am not allowed to post links yet. Any help would be greatly appreciated.
JustLookin412 is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8