Problem: CEL Issues (Please post occurence and solution) - Page 80 - Mazda3 Forums : The #1 Mazda 3 Forum
Reply
 
LinkBack Thread Tools
post #791 of 791 (permalink) Old 04-03-2016, 10:18 PM
Moped Rider
 
Wisconsinite762's Avatar
 
Join Date: Jan 2014
Posts: 23
Had a P0131 (Upstream O2 sensor Low Voltage) and an intermittent P2251(Upstream O2 Sensor Negative Current Control Circuit Open). Fixed by replacing the upstream O2 sensor.

2007 Mazda 3 2.3L M/T
Wisconsinite762 is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8