2008 Mazda 3 front right knock - Mazda3 Forums : The #1 Mazda 3 Forum
 3Likes
  • 1 Post By Mazd3
  • 1 Post By Xbeaus
  • 1 Post By Euri2004
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 01-14-2020, 01:52 PM Thread Starter
Bicycle Rider
 
Join Date: Mar 2014
Posts: 4
2008 Mazda 3 front right knock

I have a 2008 mazda 3 and there is a knock in the front right of car...Its like a rattling knock.......I have replaced the cradle arm, steering end........Knock still exist....Has anyone got or had this problem with a Mazda 3?
hatch06 likes this.
Mazd3 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-16-2020, 05:43 PM
Moped Rider
 
Join Date: Dec 2018
Location: Black Hills of South Dakota
Posts: 34
Sway bar end links? Sway bar bushings? End links are the most common.
theblooms likes this.
Xbeaus is offline  
post #3 of 4 (permalink) Old 03-02-2020, 02:12 PM
Bicycle Rider
 
Join Date: Mar 2020
Posts: 4
I have a 2004 3 2.0L at 144k miles that has been making this knocking noise for several years. I first noticed it when turning out of a parking garage and the wheel dropped an inch or two; I thought I was going crazy. Now, fast forward a few years, it's constantly banging around on slightly wavy/bumpy roads and especially when driving over potholes or man hole covers that are below the street level. The best I can describe my sound is like a bushing that has disintegrated and it's a metal-on-metal clanking around coming from the passenger side wheel well/shock mount area. It doesn't matter if I'm braking or accelerating and it seems to get worse when the wheel is turned slightly to the left on a sweeping curve. I don't feel it as much as I hear it; it's frustrating to no end and I actually wish something would just snap/fail so that at least I can identify it.

The suspension on my 3 is practically overhauled except for the most inconvenient: sway bar bushings. In the last 20k miles, and not because of this noise, I have installed Koni Orange struts and replaced all the hardware around it except for the spring, Moog endlinks (front and back), lower control arms (front), tie rods (inner and outer), and the passenger CV joint most recently. None of those made any difference.

I've read endless forums on this and different fixes seem to be the issue but most of them didn't do the work themselves so no one said specifically what component failed. My front bushings look intact and I'm not sure what it would be hitting to make such a noise, but that is the only thing that I think it left that would cause this.

You're not alone, but if you do resolve please come back and share what fixed it.
hatch06 likes this.
Euri2004 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-23-2020, 11:54 AM
Go-Kart Driver
 
Join Date: Jun 2005
Location: Dallas
Posts: 74
I’d be surprised if it isn’t your passenger side motor mount. They fail frequently, probably the least reliable part on the entire car. If that isn’t it in my experience it is usually the sway bar end links. Next after this is the ball joints. Since the ball joints can be purchased inexpensively as part of a lower control arm, I prefer replacing the entire control arm, since this yields 2 new bushings at the same time. Next in the line of suspects are failing strut upper mounts. After that the tie rod ends. I have yet to find a defective sway bar bushing to be the cause on the many 3s I have owned.

DE
Davids3 is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Mazda3 General Discussion > Mazda3 (Axela)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8