2007 Mazda 3 OEM Remote start stopped working, immobilizer problem - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-05-2018, 01:10 PM Thread Starter
Bicycle Rider
 
Join Date: Nov 2014
Location: Ottawa
Posts: 7
2007 Mazda 3 OEM Remote start stopped working, immobilizer problem

My OEM remote start has stopped working on my 2007 Mazda 3 GT with Auto transmisssion. When I press lock and start on the fob, the lights come on and it tries to start the car but the engine doesn't crank. I have noticed that when it does this, the theft link blinks rapidly which led me to think that the immobilizer is the issue. I then took my key while sitting in the car and held the black pastic part of the key containing the chip right beside the key tumbler and tried to start the car with the remote start and it started. I then tried to restart it without the key beside the tumbler and it worked a few times but the next morning it stopped working until I had the key near the tumbler again. If I take the steering column apart do you guys think I can fix it by playing with the immobilizer ribbon around the key tumbler or more than likely the immobilizer module is the issue and I would need to order a new one to replace it? I have attached the installation instructions for this remote start but it was originally installed by my dealer when I bought the car in 2007.

I also tried to do the immobilizer program procedure from the instruction manual and it didn't change anything. I disconnected the negative battery terminal, turn the key to the on position, reconnected the battery cable and then turned the key to off and then started the car with the key and then turned it off. I then put key 1 into ignition and turned it to the on position and waited for the theft light to turn off and turned key to off and removed it. Within 5 seconds I inserted key 2 and turned to on until theft light turned off and turned key to off and removed. I then tried to start the car with the remote start but the lights and blower motor can on but the theft light blink rapidly telling me the immobilizer is not working.

The other thing I never figured out prior to having this issue when the system was working as it used to, is that when I start the car it triggers the alarm. The only way I found around this is that I send the remote start command with the fob and as soon as I am done I press unlock to deactivate the alarm and then it doesn't go off once started. I don't think it should work this way but I am unsure why the remote start would trigger the alarm. The immobilizer signal must work since it let the car started. Maybe the shock sensor is triggering the alarm? I don't know if the dealer configured the sensor but when I looked under the dash I seen it there.


Remote start install instructions are at this link:

Instructions


My key fobs are the same as the ones in this thread:

http://www.mazda3forums.com/355-tech...ml#post5429202

Last edited by johnnyh55; 01-05-2018 at 01:22 PM.
johnnyh55 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-12-2018, 01:05 PM
Bicycle Rider
 
Join Date: Jan 2018
Posts: 4
I have a similar problem. I have change my battery and now each time i try to start the car, the immobilizer will start the alarm (extremely annoying system if you ask me...) and the car won't start. I try to look into the owner manual but it just say 'bring the car to dealer' which is great when car won't even start... Called the dealer, who said same thing than the book, with no help at all.
sylvain is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Mazda3 General Discussion > Mazda3 (Axela) > Technical Information, FAQ's, How-To's

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Mazda 3 2.0L 4-speed Auto Transmission Problem alvinwij Powertrain 2004-2009 Mazda3 2 03-02-2018 11:24 AM
remote start for mazda 3 2010 lockay Mazda3 (Axela) 1 11-18-2017 09:48 PM
2007 Touring Aux stopped working Spoorman 2004-2009 Electronics Discussion 5 06-22-2017 09:01 PM
2007 Mazda 3i Transmission problem Niel Introductions 0 04-16-2017 11:36 AM
2007 Mazda 3 Push to start button install HarmanNirhan Electronics Discussion 0 09-21-2016 02:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8