cel's in cold weather - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 11-09-2011, 08:43 PM   #1
mentalpatience
Moped Rider
 
Join Date: Apr 2011
Location: calgary, ab
Posts: 46
Default cel's in cold weather

my 07 ms3 threw a cel after a spirited drive at about -8 deg celsius...cant remember the cel#'s, but it was too lean at idle, then too lean off idle, then too rich off idle...... three codes total. its really thrown me for a loop, replaced the purge valve and the cel's came back after a day of driving. mods; i took the air horn at the front of the oem airbox out, and added a k&n drop in aswell as plumbed in a boost guage (checked the vac lines and no leaks) 2 resonators deleted and otherwise stock. car has 150xxx km's. the car seems fine with no hesitation. just wondering if theres anything obvious or common that would cause this? ive scoured the net and it seems usually the purge valve is the culprit, alas, cash wasted. thanks in advance!
__________________
Just scraping by... looking for 205/40/18's...
mentalpatience is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-12-2011, 10:17 PM   #2
5port
Le Mans: GT Class
 
Join Date: Oct 2007
Location: Long Island
Posts: 500
Default Re: cel's in cold weather

At 93K miles the PCV valve needs to be cleaned or replaced. When you say Purge I dont know if you mean PCV. There are a couple of DIYs on the board for it. I'm not sure the temp has anything to do with it.
__________________
Cobb SRI,RPMC TIP,FSD,Kvent,Rotella T6
5port is offline   Reply With Quote
Old 11-13-2011, 03:36 AM   #3
andjo
Le Mans: GT Class
 
Join Date: Jul 2010
Location: Houston, but my mind is in a much better place
Posts: 696
Default Re: cel's in cold weather

I've been getting a too lean cel too and I'm only at 42000. But i only get it when my ap is not plugged in. When i monitor it I dont get it... Guess I'll have to leave the ap plugged in
__________________
corksport SRI & turbo inlet hose, Viper Alarm, Pioneer AVH-3200bt, Cobb downpipe, access port, CP-E HPFP, Corksport FMIC

http://www.mazda3forums.com/index.ph...129#msg4159129
andjo is offline   Reply With Quote
Old 04-04-2012, 12:11 AM   #4
mentalpatience
Moped Rider
 
Join Date: Apr 2011
Location: calgary, ab
Posts: 46
Default Re: cel's in cold weather

@andjo, i think the accessport das an option that holds out certain cel's depending on what map youre running. And no the pcv valve hasnt been cleaned or replaced, thats an interesting thought. Im still struggling with the two codes (too lean @ idle and off idle) my obd2 reader saves freeze frame data, so does anyone know where i could find a baseline snapshot of what my freezeframe data should look like? I just want to compare values to see what areas are defficient. Ive scoured the internet and came up empty handed. My car is stock with a k&n drop in and resonator delete. Ive changed out the vaccum purge valve, plugs, checked and tightened intake and intercooler couplings, and meticulously checked vac hoses and cleaned maf... Any info is appreciated
__________________
Just scraping by... looking for 205/40/18's...
mentalpatience is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > MazdaSpeed > MazdaSpeed3 Stock Issues

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 05:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.