p0715 - input turbine speed sensor circuit malfunction. Need Part? - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 02-13-2011, 07:47 PM   #1
disciplecore24
Bicycle Rider
 
Join Date: Feb 2011
Location: Oregon USA
Posts: 8
Default p0715 - input turbine speed sensor circuit malfunction. Need Part?

Hello everyone i ran my scanner and found p0715 - input turbine speed sensor circuit malfunction. I got AT light and i didnt want to shif out of 3rd until i came to a full stop, it hasnt done it in a week and the lights went off for the AT and CE, i read it needs the sensor anyone have this problem and know where to get the sensor
My Car is a
2006 Mazda 3I 2.0 L
47k Miles
Automatic Transmission 4 speed with Auto/M shift
disciplecore24 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-17-2011, 02:53 PM   #2
ekanddsm
Le Mans: Prototype Class
 
Join Date: Apr 2007
Location: So Cal
Posts: 1,319
Default Re: p0715 - input turbine speed sensor circuit malfunction. Need Part?

Get the sensor from the dealer, make sure they ask for your vin number before you buy it, so you get the right part.

Its directly on top of the transmission, should have two wires to it, and if you can bend your arm, all you need to remove is the stock airbox to get to it.
__________________
So you have a fast______(your cars name here)????
ekanddsm is offline   Reply With Quote
Old 03-11-2011, 01:18 AM   #3
disciplecore24
Bicycle Rider
 
Join Date: Feb 2011
Location: Oregon USA
Posts: 8
Default Re: p0715 - input turbine speed sensor circuit malfunction. Need Part?

How to fix the issue
so it cost me $82.00 from Mazda dealer
Parts:

FN01-21-550

Tools:
10mm socket

Steps:

Disconnect the battery
Disconnect the ECU
Pull the battery holder
Locate the Sensor
Unbolt Sensor and disconnect harness
Connect the new sensor,do everything above in the reverse order.
disciplecore24 is offline   Reply With Quote
Old 05-30-2011, 04:09 AM   #4
samsik86
Bicycle Rider
 
Join Date: Mar 2009
Location: honolulu
Posts: 3
Default Re: p0715 - input turbine speed sensor circuit malfunction. Need Part?

Hey so did everything go back to normal? any problems after the change?
I have a 07 mazda 3 hatchback touring pkg, 28k miles
same problems stuck in 3rd gear, A/T Light and CE Light Came on..
checked for the code..didnt clear the code, started the car later,
light went off..wtf? anything else i should know before i go to the dealer?
samsik86 is offline   Reply With Quote
Old 07-08-2011, 01:28 AM   #5
niterdr
Grand Am Series
 
niterdr's Avatar
 
Join Date: Dec 2010
Location: Des Plaines, IL
Posts: 335
Default Re: p0715 - input turbine speed sensor circuit malfunction. Need Part?

i got the same code but for my fusion. i got the part from a mazda dealership - same part number as above - but its called a "pulse generator". i will replace it tomorrow and see if it fixes the issue.

i have a 2.3l with the 5spd auto tranny but my situation involves a wacky speedometer and erratic shifting. all symptoms lead to the input turbine speed sensor.
__________________
Check out my Mod Thread!!!

http://www.fordfusionclub.com/index.php?topic=186503.0
niterdr is offline   Reply With Quote
Old 08-30-2011, 12:44 AM   #6
syntrusion
Moped Rider
 
Join Date: Mar 2007
Posts: 39
Default Re: p0715 - input turbine speed sensor circuit malfunction. Need Part?

Can someone please tell me where this sensor is located? I cant find it :x A pic would help.
syntrusion is offline   Reply With Quote
Old 08-30-2011, 03:13 AM   #7
samsik86
Bicycle Rider
 
Join Date: Mar 2009
Location: honolulu
Posts: 3
Default Re: p0715 - input turbine speed sensor circuit malfunction. Need Part?

I just took mines to the dealership, didnt want to mess with it, plus if anything goes wrong within one year or 12k miles..they replace it for free..
Hope someone else on here, can help you out with the pix..cars now days..are sooo damn sensitive..good luck dude
samsik86 is offline   Reply With Quote
Old 08-30-2011, 05:41 PM   #8
mz3madmax
Short Track Racer
 
Join Date: Sep 2005
Location: South Florida
Posts: 159
Default Re: p0715 - input turbine speed sensor circuit malfunction. Need Part?

See this post for lots of info on the p0715 code.

http://www.mazda3forums.com/index.php?topic=155113.0
__________________
'06 M3s 5-door, Copper-Red Mica, 5-speed A/T
'11 M3s 5-door, Gunmetal Blue, 5-speed A/T
mz3madmax is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3 > Stock Issues

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 06:11 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.