04 mazda 3 i low idle @ stop with barke applied - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 01-24-2011, 01:48 PM   #1
ktm181
Bicycle Rider
 
Join Date: Jan 2011
Location: Kent ,WA,
Posts: 3
Default 04 mazda 3 i low idle @ stop with barke applied

I have a 04 mazda 3 I 2.3L Auto. At a stop with brake applied in drive, engine idle drops to around 450 rpm. If I let off the brake ,still in drive it returns to normal 700 rpm. in neutral or park with brake applied it has normal 700 rpm.
if I remove the Horn fuse the idle is normal in all gear positions and all brake application.
No CEL and car runs great besides the idle issue.
New spark plugs, cleaned throtel body, Newupstream o2 sensor. no help.

Can anyone help with this issue?

ktm181
ktm181 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-27-2011, 02:41 PM   #2
Frezz
Short Track Racer
 
Join Date: Mar 2010
Location: Oshkosh, WI
Posts: 125
Default Re: 04 mazda 3 i low idle @ stop with barke applied

Clean the throttle body of the car. Will fix this issue I promise
Frezz is offline   Reply With Quote
Old 01-27-2011, 03:33 PM   #3
andrew1501
Le Mans: Prototype Class
 
Join Date: Jan 2008
Posts: 2,364
Default Re: 04 mazda 3 i low idle @ stop with barke applied

i cleaned mine as well but it does it regardless. You have to understand that when you have an automatic its coupled to the engine by the torque converter. I would say that the ecu lowers the rpms when you press on the brake to help engage the the other side of the torque converter more gently. I could be wrong but i don't see any other reason as to why it would do that. it will also do it in park as well, so its not physically loading the torque converter or anything
__________________
andrew1501 is offline   Reply With Quote
Old 01-27-2011, 04:05 PM   #4
dtravman
Le Mans: GT Class
 
Join Date: Jan 2008
Location: San Diego
Posts: 798
Default Re: 04 mazda 3 i low idle @ stop with barke applied

This is just an economical fuel map. At idle, it drops really low and runs leaner to use less fuel overall. Turn on your air conditioning at idle and watch your RPMs go up a little, the AC makes that much of an actual difference in power
__________________
__________________
[[glow=red,2,300]Oo[/glow]|SKYLINE|[glow=red,2,300]oO[/glow]]
dtravman is offline   Reply With Quote
Old 01-27-2011, 04:06 PM   #5
Hexedit
Super Moderator
 
Join Date: Apr 2004
Location: New Haven, Connecticut
Posts: 8,677
Send a message via AIM to Hexedit Send a message via MSN to Hexedit
Default Re: 04 mazda 3 i low idle @ stop with barke applied

Look up PCV replacement. That is more than likely your issue.
__________________
Titanium Grey HB 5 spd, ABS, Moonroof, Leather seats, Exel RS-GT 17x7.0 Hyperblack 225/45/17 Azenis RT-615, Racing Beat Front/Rear Sway + Endlinks, Mazdaspeed MSP3 Coilovers, 88 AWR Mount, Apexcone 6000k HID, I deturboed my car and removed my built engine. I'm now stock powertrain + an Injen.
Hexedit is offline   Reply With Quote
Old 01-27-2011, 04:27 PM   #6
ktm181
Bicycle Rider
 
Join Date: Jan 2011
Location: Kent ,WA,
Posts: 3
Default Re: 04 mazda 3 i low idle @ stop with barke applied

I have already cleaned the throttle body, and it didn't help.
I have owned the car since day 1 and it has just started this issue. always held a steady 700 rpm at idle before no matter what gear or brake position.
now the idle gets so low that it runs rough and feels like it may stall. again only in drive with brake applied.
Idle is normal with AC on .
Thanks everyone for your input, keep it coming.

ktm181
ktm181 is offline   Reply With Quote
Old 01-27-2011, 05:42 PM   #7
andrew1501
Le Mans: Prototype Class
 
Join Date: Jan 2008
Posts: 2,364
Default Re: 04 mazda 3 i low idle @ stop with barke applied

if it's going low enough that it has a rolling idle, then it is probably an EGR hanging open a bit. if you can get a vid and post it that would be great.
__________________
andrew1501 is offline   Reply With Quote
Old 01-27-2011, 09:03 PM   #8
ktm181
Bicycle Rider
 
Join Date: Jan 2011
Location: Kent ,WA,
Posts: 3
Default Re: 04 mazda 3 i low idle @ stop with barke applied

I thought about the EGR also and I did look at it, seem to me moving freely, I did not remove it and clean it yet though. But if it were the EGR I should get a low / rough idle in drive without the brake applied or in park. And why would it idle normal in all gear and brake positions when I remove the horn fuse. Its got me puzzled.
I will check the PVC and the EGR again.

Thank you for the ideas.

ktm181
ktm181 is offline   Reply With Quote
Old 01-28-2011, 10:50 AM   #9
Hexedit
Super Moderator
 
Join Date: Apr 2004
Location: New Haven, Connecticut
Posts: 8,677
Send a message via AIM to Hexedit Send a message via MSN to Hexedit
Default Re: 04 mazda 3 i low idle @ stop with barke applied

[quote author=ktm181 link=topic=185300.msg3918079#msg3918079 date=1296180215]
I thought about the EGR also and I did look at it, seem to me moving freely, I did not remove it and clean it yet though. But if it were the EGR I should get a low / rough idle in drive without the brake applied or in park. And why would it idle normal in all gear and brake positions when I remove the horn fuse. Its got me puzzled.
I will check the PVC and the EGR again.

Thank you for the ideas.

ktm181
[/quote]

I'm not 100% sure how to test the PCV valve; however, replacing it fixed all my idling problems.
__________________
Titanium Grey HB 5 spd, ABS, Moonroof, Leather seats, Exel RS-GT 17x7.0 Hyperblack 225/45/17 Azenis RT-615, Racing Beat Front/Rear Sway + Endlinks, Mazdaspeed MSP3 Coilovers, 88 AWR Mount, Apexcone 6000k HID, I deturboed my car and removed my built engine. I'm now stock powertrain + an Injen.
Hexedit is offline   Reply With Quote
Old 04-30-2012, 12:30 PM   #10
chamaco
Grand Am Series
 
Join Date: Oct 2008
Posts: 254
Default Re: 04 mazda 3 i low idle @ stop with barke applied

sorry for reviving this thread, but i'm having the same issue with my 04 2.3 ATX. i want to know if by any chance the OP figure out if replacing the PCV helped or what he has done to fix it?

thanks
chamaco is online now   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3 > Powertrain Technical Information, FAQ's, How-To's

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 03:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.