Electrical system freaking out (battery light, ABS) - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 10-29-2010, 03:00 PM   #1
tomcat
Bicycle Rider
 
Join Date: Jan 2005
Location: Dallas, TX
Posts: 9
Default Electrical system freaking out (battery light, ABS)

About a week ago I noticed my battery light was on when driving. After about 10 minutes on the road it went off. The next day, my battery light was on as was my ABS light. Then my power steering started to cut out intermittently and the stereo would turn off and on. I was able to get to work and when I tried to start the car a few hours later, it would not turn over but all of the lights flashed while trying to start it (headlights, interior lights, gauges, etc). Another hour later, I was able to start it up and actually drive to Sears to have the battery tested. They said it was fine. I was able to drive home (this was on a Friday evening).

The following Monday morning I drove it to my Mazda dealer to have them look at it (didn't really believe what Sears said). On the way everything started wigging out again battery and ABS lights were on, power steering and interior lights cutting out. Once I got to Mazda, it wouldn't start again. After they had it all day, they said the alternator was fine but the battery was bad. They replaced the battery and I drove it home, no warning lights. Now it's doing the same thing as last week.

Any ideas? My car is stock, no added electrical or engine modifications, but I did have a major front-end accident about 6 months ago in which they replaced the front bumper and some of the brackets/braces(?) inside the engine compartment.
__________________
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Mazda3 5door . Titanium . Auto . Leather . Navigation . Moonroof/6-CD . ABS/SAB/SAC . Xenon/TPMS
tomcat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-29-2010, 04:01 PM   #2
john_in_the_lbc
Senior Member
 
john_in_the_lbc's Avatar
 
Join Date: Apr 2006
Location: Long Beach, California
Posts: 30,982
Default Re: Electrical system freaking out (battery light, ABS)

the lights and stuff you describe sounds the same as what others have reported when their batteries failed.
__________________
2006 Whitewater Pearl Mazda 3 S GT Hatch: Garage Vary Valiant Lip, Grill and Eyelids : Custom JL/Alpine Audio : MazdaSpeed Accessory Springs and Swaybars : JDM MazdaSpeed Strut Bar : Koni Yellows : 5Zigen Pro Racer zr520 : Continental ExtremeContact DW : Buddy Club Condenser : XE Pedals : Black Rays Lugs : HP Tint : Stubby :
My car thread http://www.mazda3forums.com/index.ph...857#msg1872857
john_in_the_lbc is online now   Reply With Quote
Old 11-03-2010, 12:24 PM   #3
tomcat
Bicycle Rider
 
Join Date: Jan 2005
Location: Dallas, TX
Posts: 9
Default Re: Electrical system freaking out (battery light, ABS)

Turns out it was the alternator, although the dealer said the first time I brought it in that it wasn't the alternator, just the battery. Working fine now after they replaced the alternator.
__________________
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Mazda3 5door . Titanium . Auto . Leather . Navigation . Moonroof/6-CD . ABS/SAB/SAC . Xenon/TPMS
tomcat is offline   Reply With Quote
Old 11-17-2010, 02:12 PM   #4
azndjay
Bicycle Rider
 
Join Date: Jul 2010
Location: MN
Posts: 9
Default Re: Electrical system freaking out (battery light, ABS)

mines doing the exact same thing . but to test it i took the battery and charge it inside. and came to start the car it was fine.. then i decided to see the Alternator , so i took the neg terminal off and the car headlight flickers on and off the car shutter to stay on so i'm guessing its a sign of the Alternator wearing down.
azndjay is offline   Reply With Quote
Old 11-22-2010, 11:46 PM   #5
azndjay
Bicycle Rider
 
Join Date: Jul 2010
Location: MN
Posts: 9
Default Re: Electrical system freaking out (battery light, ABS)

weird now everything is back to normal with the chargeing system ,so i think that it is fail soon slowing..too cold here to even replace it so going to wait til spring
azndjay is offline   Reply With Quote
Old 03-16-2011, 03:55 PM   #6
MpS
Short Track Racer
 
Join Date: Jun 2007
Posts: 134
Default Re: Electrical system freaking out (battery light, ABS)

the exact same thing happened to me today, i jumped started my car to try and take it home from down the road at a garage , jumpers on and the car started normally...thing is AS SOON as i took the jumpers out and wanted to drive away the lights came back on the car WAS MISFIRING and making like *BAAA* from the exhaust and TOTAL power loss like i had my foot flat on the accelerator and nope it just wouldnt revv!! please help me diagnose? og btw 3 lights were on ...the HANDBRAKE light , the STEERING light and the ABS light

thanx
MpS is offline   Reply With Quote
Old 11-26-2013, 01:37 PM   #7
itheearl
Go-Kart Driver
 
Join Date: Oct 2007
Posts: 75
Default

I had the exact same thing the OP describes happen yesterday on my 2007 3i (83,000 miles). It's been 20-30 degrees F.
Battery light on for a few days. As I was getting off the highway after a 20 min drive ABS light, then Power Steering light, then parking brake lights all came on and off intermittently. Radio started saying Hello over and over so powered it off. Power steering was not working at the periods where Power Steering light was on.
Pulled into a parking lot, put in Park, left engine running, turned off lights.
AT light started coming into the mix of warning lights.
After a couple minutes of the car still running everything seemed to reset. Even the battery light went out - all without turning the engine off.

Took the car to Advance and they said both the battery (almost 3 years old, biggest that will fit in the car) and alternator check out. Battery even had a high voltage (11 point something) and 500+ cranking amps. If I remember I'll scan in a pic of the battery tester printout. Battery has a 60 month prorated warranty, so i assume it should be good for another year or two yet.

This morning battery light was on again. 30 degrees F outside.
Have a long highway drive this evening, so I'm hoping that something just drained my battery a bit and the long drive will charge it up a bit.

Feel free to throw any thoughts into the mix. Maybe alternator?
__________________
2007 3i, Auto, 15% tint, Stock
itheearl is offline   Reply With Quote
Old 11-28-2013, 12:57 PM   #8
itheearl
Go-Kart Driver
 
Join Date: Oct 2007
Posts: 75
Default

Update:
It was the alternator.
Got it replaced before a 300 mile drive and everything is fine now.
__________________
2007 3i, Auto, 15% tint, Stock
itheearl is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3 > Stock Issues

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 01:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.