Mazda 3 electrical problem - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 12-27-2009, 10:37 PM   #1
caddosmith
Bicycle Rider
 
Join Date: Dec 2009
Location: Shreveport, LA
Posts: 2
Default Mazda 3 electrical problem

I have 2005 Mazda 3. Yesterday both turn and hazard signals, electric door locks and high beam indicator quit working and the brake warning light came on and stayed on. All fuses inside and under the hood checked out OK. Plenty of brake fluid. Any ideas
caddosmith is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-28-2009, 01:44 AM   #2
ekanddsm
Le Mans: Prototype Class
 
Join Date: Apr 2007
Location: So Cal
Posts: 1,319
Default Re: Mazda 3 electrical problem

Is the connector on the left side of the instrument cluster plugged in?

Sitting in the drivers seat.
__________________
So you have a fast______(your cars name here)????
ekanddsm is offline   Reply With Quote
Old 12-30-2009, 05:11 AM   #3
MzrL5
Go-Kart Driver
 
Join Date: Sep 2009
Location: Surrey,British Columbia
Posts: 60
Default Re: Mazda 3 electrical problem

try unplugging all connectors to PJB and then reconnect it.If that dont work you might need a new one. its located under glove box
MzrL5 is offline   Reply With Quote
Old 12-30-2009, 05:43 PM   #4
SpyderMonkey
Go-Kart Driver
 
Join Date: Jul 2007
Location: Miami, FL
Posts: 68
Default Re: Mazda 3 electrical problem

[quote author=caddosmith link=topic=163738.msg3473061#msg3473061 date=1261967845]
I have 2005 Mazda 3. Yesterday both turn and hazard signals, electric door locks and high beam indicator quit working and the brake warning light came on and stayed on. All fuses inside and under the hood checked out OK. Plenty of brake fluid. Any ideas
[/quote]

I have this same exact issue, I can't figure it out and don't have the funds to be ripped off by the dealership
SpyderMonkey is offline   Reply With Quote
Old 01-01-2010, 06:11 PM   #5
caddosmith
Bicycle Rider
 
Join Date: Dec 2009
Location: Shreveport, LA
Posts: 2
Default Re: Mazda 3 electrical problem

Thanks to MZRL5 suggestion of unplugging all the connections on the PJB and reconnecting them it solved the problem.

Thanks again

caddosmith
caddosmith is offline   Reply With Quote
Old 01-08-2010, 03:10 PM   #6
SpyderMonkey
Go-Kart Driver
 
Join Date: Jul 2007
Location: Miami, FL
Posts: 68
Default Re: Mazda 3 electrical problem

I forgot to reply, but yes, it was the connections on the PJB... thank you!!!
SpyderMonkey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3 > Stock Issues

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 08:22 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.