Car Won't Start After Engine Swap HELP!!! - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 09-18-2009, 06:38 PM   #1
noon21
Moped Rider
 
Join Date: Apr 2009
Location: NJ
Posts: 12
Default Car Won't Start After Engine Swap HELP!!!

I swapped out the 2.3 engine after I blew the old one. Everything is connected right and checked all the fuses and the car won't turn over. It seems that it is not getting any spark, also tried a flash test and don't get any results. Does anyone know what the problem may be? Engine cranks but doesn't start...
noon21 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-18-2009, 06:48 PM   #2
smokinamd
Moderator
 
Join Date: Dec 2004
Location: St. Louis / Bourbon, MO
Posts: 25,357
Send a message via ICQ to smokinamd Send a message via AIM to smokinamd Send a message via MSN to smokinamd Send a message via Yahoo to smokinamd
Default Re: Car Won't Start After Engine Swap HELP!!!

How long has the car been sitting?

Battery fully charged?
__________________
A revolution gets its name by always coming back around in your face.
smokinamd is offline   Reply With Quote
Old 09-18-2009, 07:04 PM   #3
dtravman
Le Mans: GT Class
 
Join Date: Jan 2008
Location: San Diego
Posts: 798
Default Re: Car Won't Start After Engine Swap HELP!!!

anytime u introduce a new ECU into the picture into any late model engine with our cars, the ECU needs to be flashed with current emission state and security (includes the VSS) settings. Have you had it flashed yet?
__________________
__________________
[[glow=red,2,300]Oo[/glow]|SKYLINE|[glow=red,2,300]oO[/glow]]
dtravman is offline   Reply With Quote
Old 09-18-2009, 07:06 PM   #4
noon21
Moped Rider
 
Join Date: Apr 2009
Location: NJ
Posts: 12
Default Re: Car Won't Start After Engine Swap HELP!!!

How do you flash it? The battery is fully charged. But the flashing thing, I've heard that from other people also. What is that and how do you do it? Thanks
noon21 is offline   Reply With Quote
Old 09-18-2009, 07:14 PM   #5
dtravman
Le Mans: GT Class
 
Join Date: Jan 2008
Location: San Diego
Posts: 798
Default Re: Car Won't Start After Engine Swap HELP!!!

oh man lol i went through the worst experience trying to get my new ECU in.  Once they installed it after they removed my other one which had been burnt up from touching a hot wire, they tried to start the car... not even a sound would be made except for the clicking of the key turning the ignition. mazda says that every ECU has to be flashed with that specific state/car/emission standards/manual transmission or automatic/etc.. all the specifics on the flash need to be exactly as your car is. But when i took it to mazda, they told me that they needed the old ECU (which was burned up and fried) to take the info off of it and put it onto the new ECU (which was blank, they dont come pre flashed like in the earlier days). Mazda said that it would take 6-8 hours to flash everything back on at $97.00 an hour... which was ridiculous. Go to your dealership and tell them to flash your car according to make, model, and emissions, federal etc.. and make sure its the right one, whether for a 2.3L or a 2.0L, cuz i have a 2.3L motor, and they had a 2.0 flashed on lol

i got good gas mileage tho, couldnt see what my average MPG was due to VSS not being flashed correctly, but i had a tank that lasted me 2 1/2 weeks
__________________
__________________
[[glow=red,2,300]Oo[/glow]|SKYLINE|[glow=red,2,300]oO[/glow]]
dtravman is offline   Reply With Quote
Old 09-18-2009, 08:20 PM   #6
smokinamd
Moderator
 
Join Date: Dec 2004
Location: St. Louis / Bourbon, MO
Posts: 25,357
Send a message via ICQ to smokinamd Send a message via AIM to smokinamd Send a message via MSN to smokinamd Send a message via Yahoo to smokinamd
Default Re: Car Won't Start After Engine Swap HELP!!!

Ugh. You don't have to get anything flashed doing a motor swap, provided you used your original wiring harness and ecu, it should fire right up.
__________________
A revolution gets its name by always coming back around in your face.
smokinamd is offline   Reply With Quote
Old 09-18-2009, 08:37 PM   #7
noon21
Moped Rider
 
Join Date: Apr 2009
Location: NJ
Posts: 12
Default Re: Car Won't Start After Engine Swap HELP!!!

smokinAMD, I figured that, I used the old harness, pretty much everything from the old motor. I don't know if its a bad connection somewhere or maybe a fuse I overlooked. But it's killing me that I can't start this car. I just need to know how to start this thing. Thanks guys all your input has been really helpful.
noon21 is offline   Reply With Quote
Old 09-18-2009, 08:54 PM   #8
smokinamd
Moderator
 
Join Date: Dec 2004
Location: St. Louis / Bourbon, MO
Posts: 25,357
Send a message via ICQ to smokinamd Send a message via AIM to smokinamd Send a message via MSN to smokinamd Send a message via Yahoo to smokinamd
Default Re: Car Won't Start After Engine Swap HELP!!!

How long has the car been sitting since you last got gas in it?
__________________
A revolution gets its name by always coming back around in your face.
smokinamd is offline   Reply With Quote
Old 09-18-2009, 09:01 PM   #9
silvapain
Grand Am Series
 
Join Date: Jun 2009
Location: Kankakee, IL
Posts: 440
Send a message via AIM to silvapain
Default Re: Car Won't Start After Engine Swap HELP!!!

Make sure the crank sensor is connected and not damaged. If no CKP signal is detected the PCM won't introduce fuel (I'm not sure about spark) when trying to start the car.
__________________
2002 Pontiac GTP 40th Anniversary Edition
2007 MS3 - Beans Above the Frank Build
silvapain is offline   Reply With Quote
Old 09-18-2009, 10:15 PM   #10
noon21
Moped Rider
 
Join Date: Apr 2009
Location: NJ
Posts: 12
Default Re: Car Won't Start After Engine Swap HELP!!!

The car sat for about 3 weeks all together. I just don't want to take it to the dealer for them to find like a loose wire or something so simple and charge me $300 know what I mean?
noon21 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 03:25 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.