automatic transmission problems???? - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 04-08-2009, 11:14 PM   #1
kcmazda3
Go-Kart Driver
 
Join Date: Dec 2006
Location: Cincinnati, OH
Posts: 68
Default automatic transmission problems????

Hey guys something weird happened on the way home from the store tonight. I was beginning to accelerate from a stop light and my car was in D, when I went to go, the dash was indicating 4 th gear and all of the sudden it went into 3 and wouldnt up shift. I then proceeded to try out the manual mode and the screen which indicates what gear you are in on the dash was blank. At this time my AT light comes on. I continue driving home and the only working gears is 1 and 3. After making it home I turn the car off and back on in a minute, no AT light. Then I drive up the road in D and back down in manual mode up shifting and downshifting through all gears, and everything works fine. Is there any problem driving the car? Is there something wrong?? Or could this be just electronic?? Any response would be greatly appreciated!!
kcmazda3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-08-2009, 11:17 PM   #2
wilb
Le Mans: GT Class
 
Join Date: Jul 2007
Location: palm beach
Posts: 513
Default Re: automatic transmission problems????

Can you give your milage and transmission service history?
wilb is offline   Reply With Quote
Old 04-08-2009, 11:18 PM   #3
kcmazda3
Go-Kart Driver
 
Join Date: Dec 2006
Location: Cincinnati, OH
Posts: 68
Default Re: automatic transmission problems????

my current mileage is 47,xxx it is an '04 and never had the tranny serviced
kcmazda3 is offline   Reply With Quote
Old 04-08-2009, 11:32 PM   #4
kcmazda3
Go-Kart Driver
 
Join Date: Dec 2006
Location: Cincinnati, OH
Posts: 68
Default Re: automatic transmission problems????

has anyone else had this problem or one similar?
kcmazda3 is offline   Reply With Quote
Old 04-09-2009, 08:25 AM   #5
thomas2717
Moped Rider
 
Join Date: Jun 2007
Posts: 28
Default Re: automatic transmission problems????

I had the same problem and the dealership pulled a code related to the "Turbine Speed Sensor". They also found a corroded J-Pipe which had to be replaced. I am sure your issue is similar to the "Turbine Speed Sensor" - the dealership charged me 145$ to replace the parts

Hope this Helps!

PS: Also make sure your Transmission Fluid is checked.
thomas2717 is offline   Reply With Quote
Old 04-09-2009, 09:57 AM   #6
3sum
Go-Kart Driver
 
Join Date: May 2007
Posts: 73
Default Re: automatic transmission problems????

you have the exact same problem as what I had and at the exact same KM as what I had it.

I was told it was something to do with a speed sensor or something. No CEL comes on, just the tranny light.

Mazda told me there was nothing wrong and refused to do any work on the car. I eventually convinced them that there was a problem and they fixed it under warranty.
If they tell you there is no problem, you might have trouble proving it to them unless it happens while you are there.

goodluck.
3sum is offline   Reply With Quote
Old 04-09-2009, 11:22 PM   #7
kcmazda3
Go-Kart Driver
 
Join Date: Dec 2006
Location: Cincinnati, OH
Posts: 68
Default Re: automatic transmission problems????

so did it come and go? today I just to and from work, app. 20 miles each way and had no problems at all?
kcmazda3 is offline   Reply With Quote
Old 04-10-2009, 08:06 PM   #8
3sum
Go-Kart Driver
 
Join Date: May 2007
Posts: 73
Default Re: automatic transmission problems????

yep, it would happen randomly. Sometimes I could turn the car off and back on again, and it would go away.

take it to mazda before it gets any worse.
3sum is offline   Reply With Quote
Old 04-15-2009, 03:15 PM   #9
reflex
Go-Kart Driver
 
Join Date: Aug 2004
Location: Port Moody, BC
Posts: 71
Default Re: automatic transmission problems????

My friend has a 04 hatchback witha 4 speed auto and the transmission just died. No warning, nothing, just driving along and stopped. Luckily she had one week left on the warranty and they will replace it. So you have to check and change the transoil because this is the weak link on this car.
__________________
2004 Mazda3 GT 2.3 Sedan
Titanium Grey
GFX Package
Automatic
20% tint on Windows and Moonroof
Stubby Antenna Wife's Car 2007 Mazda3 GT 2.3 Hatchback Sunlight Silver Luxury Package Automatic
reflex is offline   Reply With Quote
Old 04-15-2009, 03:29 PM   #10
cclngthr
Le Mans: GT Class
 
Join Date: Mar 2009
Location: Puyallup WA
Posts: 692
Send a message via AIM to cclngthr Send a message via MSN to cclngthr
Default Re: automatic transmission problems????

[quote author=reflex link=topic=141435.msg3061331#msg3061331 date=1239819309]
My friend has a 04 hatchback witha 4 speed auto and the transmission just died. No warning, nothing, just driving along and stopped. Luckily she had one week left on the warranty and they will replace it. So you have to check and change the transoil because this is the weak link on this car.
[/quote]

I'd also suggest adding a cooler to the trans that is inline with the stock cooler. Also check the battery to engine/chassis grounds. If they are loose/bad, that can make the trans shift/act erratic.
cclngthr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3 > Stock Issues

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 11:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.