Transmission goes into "Safe Mode" - Mazda3 Forums : The #1 Mazda 3 Forum


FMVPerformance.com is the premier Mazda 3 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 11-26-2008, 11:51 PM   #1
markjano
Bicycle Rider
 
Join Date: Mar 2008
Location: Chicago, Illinois
Posts: 6
Default Transmission goes into "Safe Mode"

I have a 2006 Mazda 3GT and the car has recently switched into what they call "safe mode".
then I can only stay in 3rd gear until i stop then things return to normal.. my AT light comes on and the check engine light comes on.
Anyone else having this issue. Have about 52,000 miles on it.

markjano is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-30-2008, 09:21 PM   #2
NC211
Short Track Racer
 
Join Date: Apr 2007
Posts: 104
Default Re: Transmission goes into "Safe Mode"

95% sure your fluid is bad. Check the maintenance and care section for photo instructions on how to flush it "it's super easy". Get some good fluid too, because if it's throwing "safe mode" at you with warning lights, you might be doing some damage. The fluid has probably lost it's protective attributes, which is causing it to overheat. You don't want to wait for this service either, as it can easily lead you to damaged parts, expensive parts.
NC211 is offline   Reply With Quote
Old 11-30-2008, 11:52 PM   #3
markjano
Bicycle Rider
 
Join Date: Mar 2008
Location: Chicago, Illinois
Posts: 6
Default Re: Transmission goes into "Safe Mode"

I am sorry. I forgot to mention that the dealer just did a flush. The trans fluid checked and they say it is good. Now they are saying some sensor might be bad. I will post when I take it in this week.
Thanks for you help

markjano is offline   Reply With Quote
Old 12-01-2008, 10:12 AM   #4
NC211
Short Track Racer
 
Join Date: Apr 2007
Posts: 104
Default Re: Transmission goes into "Safe Mode"

I'm always skeptical when a dealership says they did a "flush", when most say "flush", but only do the "drain n' fill" proceedure, which is nothing more than approximately 3 quarts out of the pan. The system holds twice that in the internals. Plus, I'm betting if this was your first service of the fluid, the filter in the pan is probably clogged, and if the dealer didn't drop the pan and clean it, then you've most likely got about a 1/4 of sludgish gunk in there too. Before I'd buy anything from the dealership, I'd do that proceedure HouRman did in the section I mentioned, and replace the filter too.
NC211 is offline   Reply With Quote
Old 12-04-2008, 10:04 PM   #5
markjano
Bicycle Rider
 
Join Date: Mar 2008
Location: Chicago, Illinois
Posts: 6
Default Re: Transmission goes into "Safe Mode"

So I got my car back...work done under warranty was...faulty input speed sensor. The weird thing is, I had a 99 dodge stratus and I had the same sensor go bad.
Thanks for your input on this matter.

markjano is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3 > Stock Issues

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 09:49 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.