2004 Mazda 3 electrical problem~PLEASE HELP!!!!!!! - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 10-05-2007, 10:52 PM Thread Starter
Bicycle Rider
 
Join Date: Oct 2007
Posts: 2
2004 Mazda 3 electrical problem~PLEASE HELP!!!!!!!

I have a 2004 Mazda 3, manual, I've had it for about a year and a half. I have not had any problems with it until very recently. On Wednesday night, I was driving on the way home and while driving, all the inside lights shut off and then turned back on. The car did not shut off, we did not have to restart it and the radio/clock saved the time/stations. The car was fine on Thursday and Friday morning. About 1 p.m. on Friday, I turned off the car and went into a client's house. Nothing happened when I turned off the car, but when I got back to the car after about 15 minutes and started it, the radio did not come on and the clock did not come on. The trip mileage reset itself. None of the interior lights came on. Then after about 5 minutes, the clock and the radio turned back on, but had totally reset themselves. Then after about 2-3 minutes, the radio and clock turned off again. It appears there is no power going to the radio and clock. Neither have come back on. Since that all happened, I have tried to use my key fob to lock the doors and that no longer works, nor can I lock the doors by pushing the button from the inside of the car. I have to manually lock all the doors. I also cannot unlock the doors with the key fob, but can unlock the doors with the button on the door. When I try to lock the doors from inside the car with the lock button on the door, it makes a clicking noise, but does not actually lock them. In addition, there are no inside lights at all, such as my map lights. The lights that are supposed to come on when the headlights are on are not turning on. The air conditioner resets itself everytime the car is turned off and then back on. The air is still on, but you have to push the A/C button everytime. Finally, each time the car is turned on, the gas gauge goes crazy for about 10 seconds and then stabilizes, which it had previously stabilized itself right away, and the trip mileage resets itself every time you turn the car on. I think that is everything that has happened today. We have checked all the fuses and none are blown. We have also checked the battery terminals and they are fine. I would greatly appreciate any suggestions anyone has.

Thanks,
Meghan
Meghan714 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-05-2007, 10:55 PM
F1 Driver
 
nightridermz3's Avatar
 
Join Date: Feb 2007
Location: Mays Landing, NJ
Posts: 6,667
Re: 2004 Mazda 3 electrical problem~PLEASE HELP!!!!!!!

hey meghan... welcome to the forums! Have you had anything electrical install recently (amp, sub, etc?). If not, have you tested to see if the alternator or battery have died? (using a voltmeter)? Lastly, is the car still under warranty? my guess is probably just out of the warranty, but it never hurts to check.

[img width=462 height=100]http://www.bpr-solutions.net/pics/nrsig.jpg[/img]
nightridermz3 is offline  
post #3 of 4 (permalink) Old 10-06-2007, 08:45 AM Thread Starter
Bicycle Rider
 
Join Date: Oct 2007
Posts: 2
Re: 2004 Mazda 3 electrical problem~PLEASE HELP!!!!!!!

Hey Nightrider, we have checked the battery and the terminals, but not with the voltmeter... not the alternator yet, we are going to go to Autozone today just in case to make sure they can't diagnose anything.... I don't think the car is still under the warranty, i'm still trying to find that out.... thanks so much for responding!!!!
Meghan714 is offline  
post #4 of 4 (permalink) Old 10-06-2007, 02:15 PM
F1 Driver
 
nightridermz3's Avatar
 
Join Date: Feb 2007
Location: Mays Landing, NJ
Posts: 6,667
Re: 2004 Mazda 3 electrical problem~PLEASE HELP!!!!!!!

you may be able to contact Mazda USA to find out. go to their web site, and they may have a customer service number to call. Good luck, and your welcome

[img width=462 height=100]http://www.bpr-solutions.net/pics/nrsig.jpg[/img]
nightridermz3 is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Visual / Audio > 2004-2009 Electronics Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome