Koni FSD & Eibach kit on Stock Mazda3 Rubbing - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 08-27-2016, 02:41 PM Thread Starter
Moped Rider
 
Join Date: Jul 2016
Location: Vancouver, BC
Posts: 20
Send a message via Skype™ to Motonerd
Koni FSD & Eibach kit on Stock Mazda3 Rubbing

Hi all,

I installed the above suspension last night and I've noticed that over large bumps or hard lock corners it "knocks", I believe its the Strut hitting the top of the tyre well, Has anyone else experienced this on stock standard 17x6.5 205/50/17 wheels and tyres? there's also a bit of steering wheel judder, would a wheel alignment be a smart idea?

I'd also like to add I've double checked all bolts/nuts etc

2007 Mazda3 GT Hatchback stock standard (other than struts and springs)

Last edited by Motonerd; 08-27-2016 at 03:00 PM.
Motonerd is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-30-2016, 10:36 PM
Moped Rider
 
Join Date: Mar 2014
Posts: 29
Definitely get an alignment after any suspension work. Did you replace shock/strut mounts? If those are worn it could cause the knocks. Did you check your swaybar endlinks as well as the other nuts and bolts?
koenb is offline  
post #3 of 5 (permalink) Old 08-31-2016, 12:46 PM Thread Starter
Moped Rider
 
Join Date: Jul 2016
Location: Vancouver, BC
Posts: 20
Send a message via Skype™ to Motonerd
Quote:
Originally Posted by koenb View Post
Definitely get an alignment after any suspension work. Did you replace shock/strut mounts? If those are worn it could cause the knocks. Did you check your swaybar endlinks as well as the other nuts and bolts?
I did replace my Front top hats and swaybar endlinks, checked all bolts, everything is tight. Im leaning towards the rear shock/strut mounts being worn. Any ideas where to pick up a nice pair locally to Vancouver?

EDIT: After several hours of searching I think I may have found my solution. Will check up tomorrow night and post a confirmation for all those who might be experiencing the same thing as me

Last edited by Motonerd; 08-31-2016 at 02:46 PM.
Motonerd is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 09-01-2016, 02:26 AM
Moped Rider
 
Join Date: Mar 2014
Posts: 29
Quote:
Originally Posted by Motonerd View Post
I did replace my Front top hats and swaybar endlinks, checked all bolts, everything is tight. Im leaning towards the rear shock/strut mounts being worn. Any ideas where to pick up a nice pair locally to Vancouver?

EDIT: After several hours of searching I think I may have found my solution. Will check up tomorrow night and post a confirmation for all those who might be experiencing the same thing as me
Could also be your trailing arm bushings.
koenb is offline  
post #5 of 5 (permalink) Old 09-09-2016, 09:05 AM Thread Starter
Moped Rider
 
Join Date: Jul 2016
Location: Vancouver, BC
Posts: 20
Send a message via Skype™ to Motonerd
Ok!

Problem resolved.

Turns out the Koni Struts are thinner then the stock ones, I just clamped and pressed the mount together to stop them moving, there was about 5-6mm of play...

Anyone installing (Or has installed) Koni FSD's should check theirs out, could save you/them a bit of money.
Motonerd is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Suspension / Brakes

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Image Verification
Please enter the six letters or digits that appear in the image opposite.

Registration Image

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8