Error code P2177 - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 07-20-2011, 05:02 PM Thread Starter
Moped Rider
 
Join Date: Apr 2005
Location: Whittier, CA
Posts: 46
Send a message via AIM to davillan
Error code P2177

The check engine light came on in my 2005 MZ3 S and the code it had was P2177. I have an Injen cold air intake installed pretty much since I bought the car and never had a problem so I don't suspect this to be the issue. I cleared the code a few times and it comes back within the week. I just recently put the stock airbox back in to eliminate the Injen from being the problem, I cleared the code and within a day it popped back up. The car seems to be running fine for the most part. It starts up with no problems, idles with no problems, runs pretty darn good but at times when I try to accelerate quicker and really step on the gas pedal it feels like it loses a bit of power anywhere between 2000 RPMs and 2500 RPMs. Again, I only feel this once in a while. The check engine light will turn off on its own also, but eventually comes back on. Reading through some posts some of you have had success with replacing the Purge Control Valve.

What do you guys think? Could it be the that purge valve or possibly something else? Suggestions.

2005 Mazda 3s
davillan is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-20-2011, 07:18 PM
Le Mans: Prototype Class
 
Join Date: Apr 2007
Location: So Cal
Posts: 1,319
Re: Error code P2177

look for a vacuum leak, pcv hose under the intake manifold maybe? or purge solenoid? throttle body gasket? dirty maf sensor.

So you have a fast______(your cars name here)????
ekanddsm is offline  
post #3 of 8 (permalink) Old 07-21-2011, 01:22 PM Thread Starter
Moped Rider
 
Join Date: Apr 2005
Location: Whittier, CA
Posts: 46
Send a message via AIM to davillan
Re: Error code P2177

I think the car is fixed!

I went ahead and replaced the purge valve and cleaned the MAF and so far after 65 miles of driving I have no check engine light. While I was in there I also grounded the throttle body and it did get rid of some of the bucking motion I was having when taking my foot off the gas while in second gear. The car runs real smooth now and the acceleration feels so much better, now I don't know if it's specific to just one thing that I did to the car last night or a combination of things but whatever it is, I like it.

2005 Mazda 3s
davillan is offline  
post #4 of 8 (permalink) Old 07-22-2011, 11:44 PM
Bicycle Rider
 
Join Date: Jul 2011
Location: San Diego, CA
Posts: 2
Re: Error code P2177

Check out the thread I just started:

http://www.mazda3forums.com/index.php?topic=193862.0

Its worth a read, as I have been down this road for some time.
bjagow is offline  
post #5 of 8 (permalink) Old 07-29-2011, 07:47 PM Thread Starter
Moped Rider
 
Join Date: Apr 2005
Location: Whittier, CA
Posts: 46
Send a message via AIM to davillan
Re: Error code P2177

After 1000 miles, which includes a trip to Las Vegas and back from Los Angeles, car is still running fine with no CEL codes. On the down side, my AC stopped working on the way to Vegas. The unit lasted a long time. I now have159,565 miles

2005 Mazda 3s
davillan is offline  
post #6 of 8 (permalink) Old 07-31-2011, 12:56 AM
Short Track Racer
 
Join Date: Jan 2008
Location: CA
Posts: 153
Send a message via Yahoo to deluxman
Re: Error code P2177

I had this code also when my car was around 59k mile and I had to take the car about 4 times to the dealer in 3 months. They first replaced the PSV and after driving 30 miles, CEL came back, then they replaced the fuel filter, then the fuel pump...but still CEL on. Lastly, I told them to replace the MAF sensor and it stopped the CEL. I have driven it for 40k miles and recently I had it back on again with P2177. This time I decided to clean the MAF sensor with the MAF sensor cleaner and it has been 3 days and so far so good. However, I discovered that in summer time, when weather is really hot outside, I would have an pinging noise in the engine when accelerating and night time when weather is cool, pinging noise goes away. I notice when I started to have this issue, that's when the CEL light is about to come up which indeed happen. I was not sure if I want to replace the PSV this time since I do not have issue at start up and idle is very good. I am not sure if maybe the oxygen sensor or what. I have stock intake except I used K&N air filter. I have used this filter for more than 70k miles.

I wonder if each cleaning of the MAF sensor, battery has to be disconnected so that the ECU will reset...any idea?
deluxman is offline  
post #7 of 8 (permalink) Old 07-31-2011, 01:30 AM Thread Starter
Moped Rider
 
Join Date: Apr 2005
Location: Whittier, CA
Posts: 46
Send a message via AIM to davillan
Re: Error code P2177

I never had any startup issues or idling issues either. It seems to me that no one really knows how to troubleshoot this error code, not even the dealers.

2005 Mazda 3s
davillan is offline  
post #8 of 8 (permalink) Old 07-31-2011, 01:32 AM
Short Track Racer
 
Join Date: Jan 2008
Location: CA
Posts: 153
Send a message via Yahoo to deluxman
Re: Error code P2177

Yeah, even dealer can pin point exactly what cause the P2177 code as it can be several things... PSV, fuel filter, MAF sensor, fuel pump, Oxygen sensor etc....but what I hate is that tho, dealer will try to charge you on parts that may not even be faulty...just like trial and error. I really hate the dealers.
deluxman is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Image Verification
Please enter the six letters or digits that appear in the image opposite.

Registration Image

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome