Need help with multiple issues - Mazda3 Forums : The #1 Mazda 3 Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 05-19-2017, 04:17 AM Thread Starter
Bicycle Rider
 
Unevenscore's Avatar
 
Join Date: Dec 2016
Posts: 7
Garage
Lightbulb Need help with multiple issues

Recently purchased my 3 and I've had or developed 3 main problems.
1) the passenger side xenon head light has been out since I bought the car. The bulbs were $100 so it took a while to save up and get the bulb. Finally got it and put it in. Still no light.
2) I have had a cel that is usually on but will go off once in awhile. I have a code reader and will add the code in the morning but it was a knock error.
3) I am burning though about a quart per 7-10 days approx. 400 miles.
I have limited knowledge and resources so any ideas on things I can check or count out on these issues would be greatly appreciated.
Unevenscore is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 05-19-2017, 08:47 AM
Le Mans: GT Class
 
Join Date: Jun 2012
Location: South Carolina
Posts: 569
If you're burning, and not leaking, a quart of oil every 400 miles, your motor is worn out. Sorry, but it is what it is.
theblooms is offline  
post #3 of 17 (permalink) Old 05-19-2017, 03:50 PM Thread Starter
Bicycle Rider
 
Unevenscore's Avatar
 
Join Date: Dec 2016
Posts: 7
Garage
Hmm. Sounds like my luck. Got it from a used dealer and they have a 12 month power train warranty. Guess its time to have a chat with them. What would be worn on the engine that they can check to confirm? Also would there be any noticeable performance difference?
Unevenscore is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 05-19-2017, 06:06 PM
Le Mans: Prototype Class
 
madmatt2024's Avatar
 
Join Date: Sep 2013
Location: Upstate NY
Posts: 1,285
Quote:
Originally Posted by Unevenscore View Post
Hmm. Sounds like my luck. Got it from a used dealer and they have a 12 month power train warranty. Guess its time to have a chat with them. What would be worn on the engine that they can check to confirm? Also would there be any noticeable performance difference?
Nothing that I know of. There was at least one person here that rebuilt one of these motors and still had the same oil consumption problem afterward.
madmatt2024 is offline  
post #5 of 17 (permalink) Old 05-19-2017, 10:56 PM Thread Starter
Bicycle Rider
 
Unevenscore's Avatar
 
Join Date: Dec 2016
Posts: 7
Garage
Bummer. Anyway I ordered some Kensun xenon bulbs and plan to pull the bumper off tomorrow to poke around. Any hints or suggestions of things to check when I change the bulb this time? Also do I need to disconnect the battery while I change the bulb?
Unevenscore is offline  
post #6 of 17 (permalink) Old 05-20-2017, 08:22 AM
Le Mans: Prototype Class
 
GerryBuc's Avatar
 
Join Date: Jan 2016
Location: Mundelein, IL
Posts: 1,214
The headlight light be a bad ballast.

Sent from my SAMSUNG-SM-G891A using Tapatalk
GerryBuc is offline  
post #7 of 17 (permalink) Old 05-20-2017, 12:05 PM Thread Starter
Bicycle Rider
 
Unevenscore's Avatar
 
Join Date: Dec 2016
Posts: 7
Garage
Quote:
Originally Posted by GerryBuc View Post
The headlight light be a bad ballast.

Sent from my SAMSUNG-SM-G891A using Tapatalk
Is there anyway to check the ballast to make sure its bad?
Unevenscore is offline  
post #8 of 17 (permalink) Old 05-20-2017, 02:00 PM
Bicycle Rider
 
Join Date: May 2017
Posts: 4
Hello, Im new here. We have a 2010 Mazda 3, someone hit into it during winter new bumper and fender were installed. Now the AC is not working. We just had a compressor replaced a year ago I believe, said there was holes all in it due to rocks hitting it from driving. The warranty was up 4 days ago. I looked under the hood, compressor seems to be turning. What is the issue here?
Thepiper92 is offline  
post #9 of 17 (permalink) Old 05-20-2017, 04:41 PM
Le Mans: Prototype Class
 
madmatt2024's Avatar
 
Join Date: Sep 2013
Location: Upstate NY
Posts: 1,285
Quote:
Originally Posted by Thepiper92 View Post
Hello, Im new here. We have a 2010 Mazda 3, someone hit into it during winter new bumper and fender were installed. Now the AC is not working. We just had a compressor replaced a year ago I believe, said there was holes all in it due to rocks hitting it from driving. The warranty was up 4 days ago. I looked under the hood, compressor seems to be turning. What is the issue here?
Make a new thread for your problem instead of posting in somebody elses unrelated thread.
GerryBuc likes this.
madmatt2024 is offline  
post #10 of 17 (permalink) Old 05-20-2017, 05:03 PM
Bicycle Rider
 
Join Date: May 2017
Posts: 4
Quote:
Originally Posted by madmatt2024 View Post
Make a new thread for your problem instead of posting in somebody elses unrelated thread.

Well if this forum had a better style of organization I would. I have no clue where to make the thread with my issue.
Thepiper92 is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Mazda3 General Discussion > Mazda3 (Axela)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Image Verification
Please enter the six letters or digits that appear in the image opposite.

Registration Image

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  LinkBacks (?)
LinkBack to this Thread: http://www.mazda3forums.com/57-mazda3-axela/747585-need-help-multiple-issues.html
Posted By For Type Date
Need help with multiple issues - Mazda3 Forums : The #1 Mazda 3 Forum This thread Refback 05-25-2017 06:28 PM
Need help with multiple issues - Mazda3 Forums : The #1 Mazda 3 Forum This thread Refback 05-20-2017 11:25 PM

Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 Mazda3 heater switch problem/jack issues Lawley Mazda3 (Axela) 0 04-23-2017 01:50 PM
Electrical issues rmazda Powertrain 2004-2009 Mazda3 1 04-19-2017 06:35 AM
Issues after replacing BCM Surlyphil Mazda News 1 03-09-2017 07:49 PM
Weird cold start idle issues dudeskee1325 Stock Issues 7 12-08-2016 09:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8