Security indicator light on - Car won't start - Mazda3 Forums : The #1 Mazda 3 Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 01-07-2009, 08:11 PM Thread Starter
Bicycle Rider
 
Join Date: Mar 2008
Location: Houston
Posts: 7
Security indicator light on - Car won't start

Car: Mazda3 S 2004
I just came back from holidays with the car being parked 12 days.
When I switched in ignition key to "start", the car won't star and multiple panel indicator lights (blinker, door, etc) start flashing nad making funny noises. I tried a couple of times and the same happens.
When I put the key back to ACC or ON, the Security indicator light blinks every few seconds.
The manual says this may be a the security indicator light being faulty and to contact a dealer.
Any ideas? I am based in Houston.
Thanks for the help
secchi777 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-07-2009, 08:20 PM
Short Track Racer
 
Join Date: Oct 2007
Posts: 151
Re: Security indicator light on - Car won't start

As much as I hate going to the dealer....this is one I'd go to them for.
Probably a simple ECU reflash. But you never know.
Anything come up on a Google search?
bustednutz is offline  
post #3 of 3 (permalink) Old 01-08-2009, 12:34 AM
Moped Rider
 
Join Date: Jun 2008
Posts: 27
Re: Security indicator light on - Car won't start

[quote author=secchi777 link=topic=132637.msg2848581#msg2848581 date=1231377067]
Car: Mazda3 S 2004
I just came back from holidays with the car being parked 12 days.
When I switched in ignition key to "start", the car won't star and multiple panel indicator lights (blinker, door, etc) start flashing nad making funny noises. I tried a couple of times and the same happens.
When I put the key back to ACC or ON, the Security indicator light blinks every few seconds.
The manual says this may be a the security indicator light being faulty and to contact a dealer.
Any ideas? I am based in Houston.
Thanks for the help
[/quote]

Possible battery problem. Stock battery is crap. Try a jump start.

See thread

http://www.mazda3forums.com/index.php?topic=129789.0
bigdoofus is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Technical / Model / Performance > Powertrain 2004-2009 Mazda3 > Stock Issues

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Image Verification
Please enter the six letters or digits that appear in the image opposite.

Registration Image

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome